Issue1019

Title "max_os_version" Mauvaise gestion du numéro de version Windows
Priority bug Status chatting
Superseder Nosy List agauvrit, dcardon, eblaudy, htouvet, jpele
Assigned To eblaudy Keywords

Created on 2019-10-29.16:17:49 by jpele, last changed by htouvet.

Messages
msg2130 (view) Author: jpele Date: 2019-10-29.16:17:49
Le paquet WAPT tis-powershell3 est compatible Windows Vista et 7 UNIQUEMENT
j'ai donc appliqué le filtre :

target_os         : windows
min_os_version    : 6.0
max_os_version    : 6.1

L'installation ne peut pas se lancer sur Windows 7.
Il semblerait que le max_os_version ne gère pas de la même manière le numéro de version.
msg2147 (view) Author: htouvet Date: 2019-11-13.09:03:52
min / max sont inclusifs... donc pour Vista : 
min_os_version    : 6.0
max_os_version    : 6.0
msg2148 (view) Author: jpele Date: 2019-11-13.09:16:46
use 6.1.9999
msg2149 (view) Author: htouvet Date: 2019-11-13.09:18:00
La gestion de restriction sur version ne limite pas le nombre de membres du numéro de version
...
(self.min_os_version is None or not package_entry.max_os_version or Version(package_entry.max_os_version)>=self.min_os_version) and
(self.max_os_version is None or not package_entry.min_os_version or Version(package_entry.min_os_version)<=self.max_os_version) and
...


donc pour inclure windows vista et windows 7 : 

min_os_version    : 6.0
max_os_version    : 6.1.99999
History
Date User Action Args
2019-11-13 09:18:00htouvetsetstatus: resolved -> chatting
messages: + msg2149
2019-11-13 09:16:46jpelesetstatus: chatting -> resolved
messages: + msg2148
2019-11-13 09:03:52htouvetsetstatus: chatting
messages: + msg2147
2019-10-29 16:18:03jpelesetassignedto: eblaudy
2019-10-29 16:17:49jpelecreate