tis-microsoft-teams

Questions about WAPT Packaging / Requêtes et aides autour des paquets Wapt.
Règles du forum
Règles du forum communautaire
* English support on www.reddit.com/r/wapt
* Le support communautaire en français se fait sur ce forum
* Merci de préfixer le titre du topic par [RESOLU] s'il est résolu.
* Merci de ne pas modifier un topic qui est taggé [RESOLU]. Ouvrez un nouveau topic en référençant l'ancien
* Préciser version de WAPT installée ( 1.8.2 / 2.0 / 2.1 / 2.2 / etc.) AINSI QUE l'édition Enterprise / Discovery
* Préciser OS du serveur (Linux / Windows) et version (Debian Stretch/Buster - CentOS 7 - Windows Server 2012/2016/2019)
* Préciser OS de la machine d'administration/création des paquets (Windows 7 / 10)
* Comme tout forum communautaire, le support est fait bénévolement par les membres. Si vous avez besoin d'un support commercial, vous pouvez contacter le service commercial Tranquil IT au 02.40.97.57.55
walibix
Messages : 8
Inscription : 27 juin 2019 - 16:11

16 mai 2022 - 15:21

Bonjour,

je suis désolé de vous embeter , cela devient une facheuse habitude
je suis en train de finaliser mes différents tests d'import d'une machine "existante" sur un WAPT 2.2 enterprise
j'ai remis mon lot habituel de paquets
tout ce comporte "normallement" sauf Teams

Code : Tout sélectionner

Older Microsoft Teams version found (1.4.0.22976) 
Removing: Teams Machine-Wide Installer (1.4.0.22976)
Installing: Teams_windows_1.5.0.9163_x64.msi
Traceback (most recent call last):
  File "C:\Program Files (x86)\wapt\common.py", line 4035, in install_wapt
    exitstatus = setup.install()
  File "C:\WINDOWS\TEMP\wapthk53itws\setup.py", line 49, in install
  File "C:\Program Files (x86)\wapt\common.py", line 3990, in new_func
    return func(*args, **kwargs)
  File "C:\Program Files (x86)\wapt\setuphelpers_windows.py", line 1501, in install_msi_if_needed
    run(r'msiexec /norestart /q /i "%s" %s' % (msi, props), accept_returncodes=accept_returncodes, timeout=timeout, pidlist=pidlist)
  File "C:\Program Files (x86)\wapt\waptutils.py", line 2123, in run
    raise CalledProcessErrorOutput(proc.returncode, cmd, ''.join(output))
waptutils.CalledProcessErrorOutput: Command 'msiexec /norestart /q /i "Teams_windows_1.5.0.9163_x64.msi" OPTIONS="noAutoStart=true" ALLUSER=1' returned non-zero exit status 1638.
Output:U n e   a u t r e   v e r s i o n   d e   c e   p r o d u i t   e s t   d Ú j Ó   i n s t a l l Ú e .   I m p o s s i b l e   d e   p o u r s u i v r e   l  i n s t a l l a t i o n   d e   c e t t e   v e r s i o n .   P o u r   c o n f i g u r e r   o u   s u p p r i m e r   l a   v e r s i o n   e x i s t a n t e   d e   c e   p r o d u i t ,   u t i l i s e z   l  a p p l i c a t i o n   A j o u t / S u p p r e s s i o n   d e   p r o g r a m m e s   d u   P a n n e a u   d e   c o n f i g u r a t i o n . 
 
 CalledProcessErrorOutput: Command 'msiexec /norestart /q /i "Teams_windows_1.5.0.9163_x64.msi" OPTIONS="noAutoStart=true" ALLUSER=1' returned non-zero exit status 1638.
Output:U n e   a u t r e   v e r s i o n   d e   c e   p r o d u i t   e s t   d Ú j Ó   i n s t a l l Ú e .   I m p o s s i b l e   d e   p o u r s u i v r e   l  i n s t a l l a t i o n   d e   c e t t e   v e r s i o n .   P o u r   c o n f i g u r e r   o u   s u p p r i m e r   l a   v e r s i o n   e x i s t a n t e   d e   c e   p r o d u i t ,   u t i l i s e z   l  a p p l i c a t i o n   A j o u t / S u p p r e s s i o n   d e   p r o g r a m m e s   d u   P a n n e a u   d e   c o n f i g u r a t i o n . 
 
une idée ?

Merci d'avance
Avatar de l’utilisateur
jpele
Messages : 88
Inscription : 04 mars 2019 - 12:01
Localisation : Nantes

16 mai 2022 - 17:39

Bonjour,
Je pense qu'il faut rebooter la machine, il doit y avoir trop de différence entre ces deux versions et Microsoft à tendance à effectuer la suppression des fichiers restants de certain logiciel au reboot.
Reboot puis une nouvelle tentative d'installation devrait résoudre le soucis.

Cordialement,
Jimmy
walibix
Messages : 8
Inscription : 27 juin 2019 - 16:11

17 mai 2022 - 07:45

Bonjour,

non malheuresement après reboot même diagnostique

Cordialement
Avatar de l’utilisateur
dcardon
Expert WAPT
Messages : 801
Inscription : 18 juin 2014 - 09:58
Localisation : Nantes
Contact :

17 mai 2022 - 13:27

Bonjour,

le paquet est censé désinstaller teams avant de le ré-installer (cf. ligne Removing: Teams Machine-Wide Installer (1.4.0.22976) ). Est ce que vous avez encore Teams dans installer / désinstaller des programmes après. Est ce que vous voyez des restes en lançant la ligne suivante ?

Code : Tout sélectionner

wapt-get list-registry teams


Si vous essayer de le désinstaller à la main, ça donne quoi? est ce que le paquet s'installe correctement après?

Au fait, ça ne semble pas être la dernière version du paquet teams que vous avez, est ce que vous pourriez essayer avec une version plus récente?

Cordialement,

Denis
Denis Cardon - Tranquil IT
Communiquez autour de vous sur WAPT! Envoyez nous vos url de blog et d'articles dans la catégorie votre avis du forum, nous les mettrons en avant sur le site WAPT
walibix
Messages : 8
Inscription : 27 juin 2019 - 16:11

18 mai 2022 - 11:03

Bonjour,

effectivement Teams Machine Wide était toujours présent
je l'ai déinstallé
wapt-get list-registry teams me fait une réponse vide

relance de l'installation : (avec le nouveau paquet)

Code : Tout sélectionner

Installing: Teams_windows_1.5.0.11163_x64.msi
Traceback (most recent call last):
  File "C:\Program Files (x86)\wapt\common.py", line 4035, in install_wapt
    exitstatus = setup.install()
  File "C:\WINDOWS\TEMP\wapt0hf86vu0\setup.py", line 49, in install
  File "C:\Program Files (x86)\wapt\common.py", line 3990, in new_func
    return func(*args, **kwargs)
  File "C:\Program Files (x86)\wapt\setuphelpers_windows.py", line 1501, in install_msi_if_needed
    run(r'msiexec /norestart /q /i "%s" %s' % (msi, props), accept_returncodes=accept_returncodes, timeout=timeout, pidlist=pidlist)
  File "C:\Program Files (x86)\wapt\waptutils.py", line 2123, in run
    raise CalledProcessErrorOutput(proc.returncode, cmd, ''.join(output))
waptutils.CalledProcessErrorOutput: Command 'msiexec /norestart /q /i "Teams_windows_1.5.0.11163_x64.msi" OPTIONS="noAutoStart=true" ALLUSER=1' returned non-zero exit status 1603.
Output:

CalledProcessErrorOutput: Command 'msiexec /norestart /q /i "Teams_windows_1.5.0.11163_x64.msi" OPTIONS="noAutoStart=true" ALLUSER=1' returned non-zero exit status 1603.
Output:
Merci encore

Cordialement
Avatar de l’utilisateur
jpele
Messages : 88
Inscription : 04 mars 2019 - 12:01
Localisation : Nantes

18 mai 2022 - 14:23

Bonjour,
Quel paquet tentez-vous d'installer ?
Quel est le pourcentage de poste impactés pour ce paquet ?
Le PC a-t-il bien été redémarré après la désinstallation ?

Cordialement,
Jimmy
walibix
Messages : 8
Inscription : 27 juin 2019 - 16:11

19 mai 2022 - 16:18

Bonjour,

tis-microsoft-teams v 1.5.0.11163-65 // Windows // 64 bits // PROD du 16-05-2022

pourcentage de poste postes impactés, comme ce sont des postes de tests : 100% ? (1/1)
redemarrage de nombreuse fois

Merci encore

Cordialement
Avatar de l’utilisateur
jpele
Messages : 88
Inscription : 04 mars 2019 - 12:01
Localisation : Nantes

20 mai 2022 - 14:43

Bonjour,
Je n'ai pas d'autres pistes, il faudrait corriger l'installation manuellement :
Une piste fonctionnelle : https://support.microsoft.com/topic/fix ... f927e1eb4d

Je ne pense pas que des PC de production seront impacté, à vous de tester sur de petite portions.
Le cas échéant je vous invite à prendre du support personnalisé qui nous permettra de résoudre votre soucis.

Cordialement,
Jimmy
Répondre