Option silencieuse grisée lors de la création du paquet

Share here your tips or issues concerning WAPT Console or WAPT Agent / Venez ici partager vos problèmes et astuces concernants la console et l'agent WAPT
Règles du forum
Règles du forum communautaire
* English support on www.reddit.com/r/wapt
* Le support communautaire en français se fait sur ce forum
* Merci de préfixer le titre du topic par [RESOLU] s'il est résolu.
* Merci de ne pas modifier un topic qui est taggé [RESOLU]. Ouvrez un nouveau topic en référençant l'ancien
* Préciser version de WAPT installée ( 1.8.2 / 2.0 / 2.1 / 2.2 / etc.) AINSI QUE l'édition Enterprise / Discovery
* Préciser OS du serveur (Linux / Windows) et version (Debian Stretch/Buster - CentOS 7 - Windows Server 2012/2016/2019)
* Préciser OS de la machine d'administration/création des paquets (Windows 7 / 10)
* Comme tout forum communautaire, le support est fait bénévolement par les membres. Si vous avez besoin d'un support commercial, vous pouvez contacter le service commercial Tranquil IT au 02.40.97.57.55
Sebo_Lavie
Messages : 3
Inscription : 06 mai 2022 - 10:08

12 mai 2022 - 11:43

Bonjour à toutes et à tous,

je me permet de vous contacter car je rencontre un petit soucis pour la création de paquets.

Quand je veux creer un paquet en passant par l'assistant de création de paquet, la ligne pour les options silencieuses et grisée et donc je ne peux pas ajouter mes arguments pour le .msi que je souhaite packager...

j'ai ca depuis la mise à jour vers la console Discovery 2.2.1.11899 alors qu'avec la version 1.8 je n'avais pas ce soucis. est ce que j'ai oublié un step lors de la mise à jour? ou la version discovery ne permet plus d'utiliser cette fonctionnalité?
un grand merci d'avance pour votre retour!!
En attente de vous lire, je vous souhaite une excellent journée et vous dis à bientot!!

--------------------
WAPTConsole Discovery version 2.2.1.11.899
OS du serveur : Windows Serveur 2016
OS postes de travail : Windows 10
Pièces jointes
capture d'écran
capture d'écran
wpat.jpg (11.34 Kio) Consulté 120 fois
Avatar de l’utilisateur
sfonteneau
Expert WAPT
Messages : 1352
Inscription : 10 juil. 2014 - 23:52
Contact :

12 mai 2022 - 12:48

Bonjour

C'est volontaire (version discovery et entreprise confondu)

Vous devez passer par le bouton "editer manuellement" pour ajouter des arguments supplémentaire.
Et du coup tester dans (pyscripter/vscode) que vos argument supplémentaire marche

Simon
Sebo_Lavie
Messages : 3
Inscription : 06 mai 2022 - 10:08

12 mai 2022 - 14:24

Bonjour Simon,

tout d'abord merci pour votre réponse.

j'ai installé la version 4 de PyScripter, malheureusement mes compétences s'arretent là, je n'ai totalement aucune notion de ce qu'il faut faire..

Seb
Sebo_Lavie
Messages : 3
Inscription : 06 mai 2022 - 10:08

12 mai 2022 - 14:50

bon ok...
j'ai regardé un peu les packages téléchargés et si j'ai a vue d'oeil bien compris....

je crée mon package et je l'édite manuellement, je rajoute à la main mes arguments par exemple en commencant par silentflags=' ?

exemple :

Code : Tout sélectionner

def install():
    # Declaring local variables

    # Installing the software
    print("Installing: monlogiciel.msi")
    install_msi_if_needed('monlogiciel.msi')
    silentflags='/argumentA /argumentB /argumentC /log=%computername%_monlogiciel.txt'
je teste si tout est ok en executant un install, et si cela fonctionne, j'execute un -ibuild-upload

j'ai bon?!
Répondre