[RESOLU] PB PXE NBP file size 0 Bytes

Question about WAPT Server / Requêtes et aides autour du serveur Wapt
Règles du forum
Règles du forum communautaire
* English support on www.reddit.com/r/wapt
* Le support communautaire en français se fait sur ce forum
* Merci de préfixer le titre du topic par [RESOLU] s'il est résolu.
* Merci de ne pas modifier un topic qui est taggé [RESOLU]. Ouvrez un nouveau topic en référençant l'ancien
* Préciser version de WAPT installée ( 1.8.2 / 2.0 / 2.1 / 2.2 / etc.) AINSI QUE l'édition Enterprise / Discovery
* Préciser OS du serveur (Linux / Windows) et version (Debian Stretch/Buster - CentOS 7 - Windows Server 2012/2016/2019)
* Préciser OS de la machine d'administration/création des paquets (Windows 7 / 10)
* Comme tout forum communautaire, le support est fait bénévolement par les membres. Si vous avez besoin d'un support commercial, vous pouvez contacter le service commercial Tranquil IT au 02.40.97.57.55
bruno67
Messages : 20
Inscription : 02 août 2018 - 11:39

14 avr. 2022 - 15:04

Bonjour,

je viens de passer des heures avec cette erreur lors d'une tentative de déploiement via PXE
pxe.png
pxe.png (2.79 Kio) Consulté 396 fois
NBP file name is ipxe.efi
NBP filesize is 0bytes
download succeed

et le PC refusait de booter

Nous disposons d'un serveur isc dhcp sous linux et il faut préciser la taille du fichier IPXE qui sera téléchargé, pour compliquer les choses ce fichier doit être divisé par 512
Cette obligation se fait à partir des bios UEFI supérieur à 2.3

si ça peut aider .....
Avatar de l’utilisateur
dcardon
Expert WAPT
Messages : 797
Inscription : 18 juin 2014 - 09:58
Localisation : Nantes
Contact :

15 avr. 2022 - 14:33

Bonjour Bruno67,

est ce que vous avez désactivé le secureboot sur votre machine? J'ai déjà eu exactement le même comportement sur des portables Lenovo avec secureboot activé alors que le ipxe n'est pas signé.
Le binaire ipxe qui est fournit par le projet ipxe n'est pas signé pour secureboot, si vous voulez garder secureboot pendant l'installation initiale il faut:
* acheter une licence ipxe anywhere auprès de 2pints software
* faire un boot sans ipxe (boot direct sur le bcd microsoft)

Cordialement,

Denis
Denis Cardon - Tranquil IT
Communiquez autour de vous sur WAPT! Envoyez nous vos url de blog et d'articles dans la catégorie votre avis du forum, nous les mettrons en avant sur le site WAPT
bruno67
Messages : 20
Inscription : 02 août 2018 - 11:39

19 avr. 2022 - 15:52

en faisant la modification de taille du fichier PXE dans le serveur DHCP, le téléchargement du ipxe se déroule correctement
Avatar de l’utilisateur
dcardon
Expert WAPT
Messages : 797
Inscription : 18 juin 2014 - 09:58
Localisation : Nantes
Contact :

20 avr. 2022 - 12:37

Bonjour Bruno67,

on a des laptop en secureboot pour les tests/développement interne sur WADS, et le secureboot est arrivé avec les spec UEFI 2.3.1, il n'est donc pas toujours nécessaire de le spécifier.

Ca dépend peut être des implémentations. C'est quoi le modèle de portable que vous avez (fabricant et référence exacte)?

Cordialement,

Denis
Denis Cardon - Tranquil IT
Communiquez autour de vous sur WAPT! Envoyez nous vos url de blog et d'articles dans la catégorie votre avis du forum, nous les mettrons en avant sur le site WAPT
Avatar de l’utilisateur
dcardon
Expert WAPT
Messages : 797
Inscription : 18 juin 2014 - 09:58
Localisation : Nantes
Contact :

27 avr. 2022 - 17:25

Bonjour Bruno67,

après recherche on a trouvé un soucis dans la réponse du serveur TFTP où la variable tsize dans la réponse tftp a un caractère null \0 en trop, ce qui peut poser un problème à certain client tftp. On est entrain de corriger et de valider le correctif. On a trouvé en interne un portable qui présente le même comportement que vous, on peut donc reproduire le soucis et valider le correctif.

Cordialement,

Denis
Denis Cardon - Tranquil IT
Communiquez autour de vous sur WAPT! Envoyez nous vos url de blog et d'articles dans la catégorie votre avis du forum, nous les mettrons en avant sur le site WAPT
smandel
Messages : 49
Inscription : 05 mai 2022 - 11:30

18 mai 2022 - 17:42

Bonjour,

je viens d'essayer un déploiement sur un PC récent et le boot PXE en UEFI reste bloqué à :

Code : Tout sélectionner

Downloading NBP file...
Le secure boot a été désactivé.
Je sèche...
Avatar de l’utilisateur
sfonteneau
Expert WAPT
Messages : 1346
Inscription : 10 juil. 2014 - 23:52
Contact :

18 mai 2022 - 18:15

Bonjour

Vous pouvez essayer avec la dernière release que je viens de push ?

https://wapt.tranquil.it/wapt/releases/ ... -1b2dfbee/

Simon Fonteneau
smandel
Messages : 49
Inscription : 05 mai 2022 - 11:30

19 mai 2022 - 09:17

Bonjour Simon,

j'ai poussé la dernière version sur notre serveur ce matin mais pas mieux...
Avatar de l’utilisateur
sfonteneau
Expert WAPT
Messages : 1346
Inscription : 10 juil. 2014 - 23:52
Contact :

19 mai 2022 - 09:44

Pouvez-vous me donner le system d'exploitation du serveur( windows/debian/redhat) ?

êtes vous en wapttftpserver ?

Je voudrais essayer de vous basculer sur un autre serveur tftp pour voir si c'est mieux mais il me faut le system pour mieux vous guider
smandel
Messages : 49
Inscription : 05 mai 2022 - 11:30

19 mai 2022 - 13:40

Nous sommes sur un server Debian 11 avec le wapttftpserver.
Répondre