[RESOLU] Néophyte - Problème sur les certificats

Question about WAPT Server / Requêtes et aides autour du serveur Wapt
Règles du forum
Règles du forum communautaire
* English support on www.reddit.com/r/wapt
* Le support communautaire en français se fait sur ce forum
* Merci de préfixer le titre du topic par [RESOLU] s'il est résolu.
* Merci de ne pas modifier un topic qui est taggé [RESOLU]. Ouvrez un nouveau topic en référençant l'ancien
* Préciser version de WAPT installée ( 1.8.2 / 2.0 / 2.1 / 2.2 / etc.) AINSI QUE l'édition Enterprise / Discovery
* Préciser OS du serveur (Linux / Windows) et version (Debian Stretch/Buster - CentOS 7 - Windows Server 2012/2016/2019)
* Préciser OS de la machine d'administration/création des paquets (Windows 7 / 10)
* Comme tout forum communautaire, le support est fait bénévolement par les membres. Si vous avez besoin d'un support commercial, vous pouvez contacter le service commercial Tranquil IT au 02.40.97.57.55
Duster
Messages : 2
Inscription : 19 janv. 2022 - 12:20

19 janv. 2022 - 12:39

Bonjour à toute la communauté,

Pour commencer, voici les informations essentielles sur ma version de WAPT :
Version WAPT Enterprise 2.1.2.10605
Installé sur une machine windows 10 pour l'instant

Et maintenant un peu de background :
Je travaille dans un petit service informatique ou l'on m'a chargé du déploiement de WAPT sur le parc informatique. Dans le service aucun d'entre nous n'a su trouver de solution au problème que je rencontre, je me permets donc de poster ici. J'ai installé le serveur WAPT sur une machine Windows 10 dédiée afin de tester l'ensemble du système avant de tout migrer proprement sur le serveur définitif. J'ai peu de connaissances en matière de certificats web ssl, protocole HTTPS et c'est pourquoi je demande votre aide.

Difficulté rencontrée :

Mes machines de test ne remontent pas dans la console WAPT, en réalisant une commande trouvée dans la doc : wapt-get enable-check-certficate j'obtiens l'erreur suivante :
WARNING Warning, certificate CN NOMDUSERVEUR.lan sent by server does not match URL host NOMDUSERVEUR
Server certificate : C:\Program Files (x86)\wapt\ssl\server\NOMDUSERVEUR.lan.crt


Et la suite, avec plusieurs autres lignes indiquant que le hostname ne figure pas dans l'extension subjectaltnames du certificat...

Lorsque je récupère le certificat https du serveur via le bouton dans les préférences, je remarque que le nom de ce certificat est terminé par .lan, et j'aimerai que le serveur soit accessible en local. Une adresse IP fixe a été attribuée au serveur pour cet usage.

Je ne comprends pas ou se situe mon erreur, j'ai bien entendu recherché et trouvé dans la doc et le forum différents éléments m'indiquant entre autre de re-générer le certificat, j'ai également réinstallé le serveur mais je ne parviens pas à contourner ce problème...

Je suis sur que je fais mal quelque chose.

Une âme charitable serait-elle en mesure de m'aiguiller ?

Je vous remercie !

EDIT : Il s'agissait d'une erreur de DNS dans ma configuration
Dernière modification par Duster le 04 févr. 2022 - 10:01, modifié 1 fois.
Avatar de l’utilisateur
sfonteneau
Expert WAPT
Messages : 1297
Inscription : 10 juil. 2014 - 23:52
Contact :

20 janv. 2022 - 09:40

Bonjour

Avez-vous remplacer le certificat autosigné du serveur wapt ou alors avez-vous laisser l'installation par défaut ?

L'erreur est celle-ci :

L'adresse indiquée dans le wapt-get.ini ne correspond pas a l'adresse indiqué dans le certificat

êtes vous avec un serveur sous windows ou sous linux ?

Simon
Duster
Messages : 2
Inscription : 19 janv. 2022 - 12:20

21 janv. 2022 - 08:52

Bonjour Simon,

Merci pour votre message !

Je n'ai pas remplacé le certificat autosigné du serveur WAPT. J'ai procédé à l'installation comme indiqué dans la documentation pour la version 2.1. Le serveur tourne sous Windows

Bien à vous,
Répondre