[RESOLU] Erreur Module platform avec paquet LINUX

Questions about WAPT Packaging / Requêtes et aides autour des paquets Wapt.
Règles du forum
Règles du forum communautaire
* English support on www.reddit.com/r/wapt
* Le support communautaire en français se fait sur ce forum
* Merci de préfixer le titre du topic par [RESOLU] s'il est résolu.
* Merci de ne pas modifier un topic qui est taggé [RESOLU]. Ouvrez un nouveau topic en référençant l'ancien
* Préciser version de WAPT installée ( 1.8.2 / 2.0 / 2.1 / 2.2 / etc.) AINSI QUE l'édition Enterprise / Discovery
* Préciser OS du serveur (Linux / Windows) et version (Debian Stretch/Buster - CentOS 7 - Windows Server 2012/2016/2019)
* Préciser OS de la machine d'administration/création des paquets (Windows 7 / 10)
* Comme tout forum communautaire, le support est fait bénévolement par les membres. Si vous avez besoin d'un support commercial, vous pouvez contacter le service commercial Tranquil IT au 02.40.97.57.55
Pierrehenry
Messages : 1
Inscription : 28 juin 2021 - 11:16

28 juin 2021 - 11:20

Bonjour,

J’ai voulu installer de paquets sur un PC Linux après l’avoir enregistré sur le serveur.
Lors de l’installation, j’avais une erreur avec le module platform et l’attribut linux_distribution.
J’ai remplacé le module platform par le module distro et l’installation s’est bien passée.
Je ne sais pas si d’autres personnes ont eu le même problème et si c’est la bonne solution

AttributeError: module 'platform' has no attribute 'linux_distribution'
AttributeError: module 'platform' has no attribute 'linux_distribution'

Paquet : VLC et Anydesk
Version Linux : Ubuntu 20.04
Versition WAPT 2.0 9428 Enterprise
Avatar de l’utilisateur
dcardon
Expert WAPT
Messages : 806
Inscription : 18 juin 2014 - 09:58
Localisation : Nantes
Contact :

30 juin 2021 - 10:33

Bonjour Pierrehenry,
en effet, avec le passage en python3.8 la fonction linux_distribution() a été passé du module platform au module distro... On a corrigé dans le dernier build et je vais le pousser en nightly bientôt.
Denis
Denis Cardon - Tranquil IT
Communiquez autour de vous sur WAPT! Envoyez nous vos url de blog et d'articles dans la catégorie votre avis du forum, nous les mettrons en avant sur le site WAPT
Avatar de l’utilisateur
dcardon
Expert WAPT
Messages : 806
Inscription : 18 juin 2014 - 09:58
Localisation : Nantes
Contact :

07 juil. 2021 - 17:10

C'est corrigé dans la prochaine version 2.1 qui devrait sortir bientôt.
Denis
Denis Cardon - Tranquil IT
Communiquez autour de vous sur WAPT! Envoyez nous vos url de blog et d'articles dans la catégorie votre avis du forum, nous les mettrons en avant sur le site WAPT
sparda53
Messages : 1
Inscription : 09 déc. 2021 - 17:57

09 déc. 2021 - 18:01

Bonjour,
J'ai le même soucis avec la version 2.1 installé récemment.
Faut il toujours faire la modif manuellement ?
Cdt
Répondre