Déploiement non fonctionnel via compte système et administrateur

Questions about WAPT Packaging / Requêtes et aides autour des paquets Wapt.
Règles du forum
Règles du forum communautaire
* English support on www.reddit.com/r/wapt
* Le support communautaire en français se fait sur ce forum
* Merci de préfixer le titre du topic par [RESOLU] s'il est résolu.
* Merci de ne pas modifier un topic qui est taggé [RESOLU]. Ouvrez un nouveau topic en référençant l'ancien
* Préciser version de WAPT installée ( 1.8.2 / 2.0 / 2.1 / 2.2 / etc.) AINSI QUE l'édition Enterprise / Discovery
* Préciser OS du serveur (Linux / Windows) et version (Debian Stretch/Buster - CentOS 7 - Windows Server 2012/2016/2019)
* Préciser OS de la machine d'administration/création des paquets (Windows 7 / 10)
* Comme tout forum communautaire, le support est fait bénévolement par les membres. Si vous avez besoin d'un support commercial, vous pouvez contacter le service commercial Tranquil IT au 02.40.97.57.55
TomTom
Messages : 35
Inscription : 25 mai 2018 - 15:43

06 déc. 2021 - 11:32

Bonjour à tous,

Je butte sur un déploiement du logiciel d'édition d'étiquettes Bartender dans sa version 2019. Je n'arrive à le déployer ni avec le compte system, ni avec la commande run_as_administrator.
Voici mon setup.py:

Code : Tout sélectionner

# -*- coding: utf-8 -*-
from setuphelpers import *

"""
Usable WAPT package functions: install(), uninstall(), session_setup(), audit(), update_package()

"""
# Declaring global variables - Warnings: 1) WAPT context is only available in package functions; 2) Global variables are not persistent between calls


def install():
    # Declaring local variables

    # Installing the software
    if installed_softwares('BarTender 2019 R10'):
        print('Bartender 2019 already installed skipping...')
    else:
        print("Installing: %s" % control.package)
        run_as_administrator(r'"BT2019_R10_167038_Full.exe" FEATURE=BarTender PKC="XXXX-XXXX-XXXX-XXXX" BLS=<server>:<port> INSTALLSQL=false')
    #install_exe_if_needed('BT2019_R10_167038_Full.exe',
    #    silentflags='FEATURE=BarTender PKC="XXXX-XXXX-XXXX-XXXX" BLS=<server>:<port> INSTALLSQL=false',
    #    key='{CC605B77-CED6-400B-B41E-B592EB50D7C1}',
    #    min_version=control.get_software_version(),
    #    timeout=1200,
    #)

def uninstall():
    run_notfatal(r'MsiExec.exe /X{CC605B77-CED6-400B-B41E-B592EB50D7C1} /qn')

Si un expert pouvais m'aiguiller sur des pistes éventuelles... J'ai des dizaines de postes à mettre à jour et je ne me vois pas le faire manuellement.

Merci d'avance
Thomas
Version de WAPT : 2.1 (Enterprise Edition)
OS du serveur : Debian 10 "Buster"
OS de la machine d'administration/création des paquets : Windows 10 20h2
florentR2
Messages : 85
Inscription : 13 févr. 2020 - 17:23

06 déc. 2021 - 14:22

As-tu le meme soucis en le déployant avec un Psexec -i -s cmd ?

On a un package capricieux du même type (EBP pour ne pas le citer) et c'est le SQL qui pose souci en compte system.
TomTom
Messages : 35
Inscription : 25 mai 2018 - 15:43

06 déc. 2021 - 16:04

Je ne peux malheureusement pas tester avec les commandes de psexec. Il est blacklisté par notre maison mère...
Version de WAPT : 2.1 (Enterprise Edition)
OS du serveur : Debian 10 "Buster"
OS de la machine d'administration/création des paquets : Windows 10 20h2
florentR2
Messages : 85
Inscription : 13 févr. 2020 - 17:23

07 déc. 2021 - 09:19

Même dans une vm vierge hors réseau ?
TomTom
Messages : 35
Inscription : 25 mai 2018 - 15:43

21 déc. 2021 - 09:15

Pas encore pu le tester (pas beaucoup de temps à consacrer à ça en ce moment j'avoue)
Pour le moment je déploiement "à l'ancienne"
Je verrais quand j'arriverais à me dégager du temps.

Merci en tout cas
Version de WAPT : 2.1 (Enterprise Edition)
OS du serveur : Debian 10 "Buster"
OS de la machine d'administration/création des paquets : Windows 10 20h2
Répondre